ジョブの実行遅延について
Incident Report for Cloud Automator
Postmortem

いつもCloud Automatorをご利用いただきありがとうございます。
下記の時間帯で発生しておりました、障害についてご報告差し上げます。

障害の概要

  • 10月15日にリリースした「タイマートリガージョブの実行日時のタイムゾーン指定」に不具合があり、ジョブの実行開始に遅延が発生
  • 現在は暫定対応を実施し、システムは正常に稼働中
  • 恒久対応は2019年10月24日(木)までに実施予定

発生日時

  • 2019年10月15日23時00分 〜 2019年10月16日15時35分(日本時間)

影響範囲

  • タイマートリガーで有効期間(開始日 and/or 終了日)が設定されているジョブのうち、上記期間に実行開始したジョブの実行開始に遅延が発生

障害による影響の確認方法

  • 障害発生期間に開始された実行ログの開始日時と、2019年10月14日以前の開始日時を比較し、遅延を確認

障害の原因

  • 「タイマートリガージョブの実行日時のタイムゾーン指定」機能における不具合

暫定対応

  • 不具合のあった処理を除外するよう修正済み

恒久対応

  • Cloud Automator内部のAPI通信において、タイマートリガーの有効期間のバリデーション方法を修正予定

この度はご迷惑をお掛け致しましたことをお詫び申し上げます。
今後とも、Cloud Automator をよろしくお願いいたします。

Posted Oct 17, 2019 - 16:39 JST

Resolved
いつも Cloud Automator をご利用頂きありがとうございます。
下記の時間におきまして発生しておりました、ジョブの実行遅延障害が復旧致しました。

■発生期間
2019年10月15日23時00分 〜 2019年10月16日11時00分

■発生原因
Cloud Automator の内部で利用している API の一部処理で不具合があったため、
ジョブの実行が遅延する状況となっておりました。

■次回以降のジョブについて
現在は、不具合のあった処理を除外するように修正済みで
次回以降のジョブについては予定通り実行されます。

この度はご迷惑をお掛け致しましたことをお詫び申し上げます。
今後とも、Cloud Automator をよろしくお願いいたします。
Posted Oct 16, 2019 - 16:08 JST
Investigating
いつもCloud Automatorをご利用頂きましてありがとうございます。

現在、Cloud Automatorのジョブ実行に遅延が発生する障害が発生しております。
原因につきましてはただ今調査しておりますので、分かり次第ご報告差し上げます。

お客様にはご迷惑をお掛け致しまして大変申し訳ございません。
Posted Oct 16, 2019 - 11:13 JST
This incident affected: Cloud Automator (worker).